Panne Serveur BrandMesiter France

Une grosse panne perturbait le serveur BrandMeister France depuis quelques temps et ceci apparemment depuis la dernière mise à jour.

L’équipe sous la houlette de Michel F1TZO assisté de Rudy FD0ZRY se sont penchés sur les problèmes afin de faire les résolutions nécessaires.

Bravo à tous pour le travail qui n’était pas évident à résoudre.

Voici le communiqué BM FR sur la situation et résolution des problèmes du serveur:

Bonjour à tous

Vous avez tous constater les soucis subit par le BM ces derniers jours.
Ceux ci sont maintenant réglés, et il est utile de faire le point sur ces incidents.

J’en profite pour remercier des personnes qui nous ont aider à qualifier les soucis : F4GEN, F4EGG, F0GBY (pour les test RX), et sans doute d’autres que j’oublie, ce dont je vous pris de m’excuser.

Résumé des Problèmes constatés (dans l’ordre ou nous les avons découverts ou par informations remontées ):
    – Freeze du BM : plus de connexion possible
    – EN DMR  : Plus de réception ou alors pas par tous les destinataires
    – TG Dynamiques : 1 seule affectation possible, les autres nodes n’y avaient plus accès (sensation d’aléatoire)

Les soucis rencontrés proviennent sans doute de la dernière mise à jour, qui a “zapper” 1 fichier important et créer de par le fait les effets de bords constatés.

Le Freeze du BM : celui ci étant partiellement mis à jour, des tables et des buffers se sont remplis anormalement, jusqu’au freeze par manque de ressources allouée.
-> Un redémarrage et ça repart, mais hélas sans résoudre le problème … Typique des PB les plus @#%! car on ne voie rien ….

Heureusement, les 2 autres problèmes sont apparues (sic). Si, si, heureusement car cela à permis, via un boulot de qualification détaillé (merci Patrice pour ton temps passé lors des tests !) de cerner précisément les points clés et ensuite de pouvoir agir.

DMR : plus de réception systématique (certains recevaient, d’autres non – la majorité)
-> Là, une fois constaté (vendredi soir), ce fut plus rapide, le fichier en cause à été vite (3h…) identifié.
… mais que devait il contenir par rapport à la MAJ ….
La, avec l’aide de Rudy, ce fut réglé à la volée dès samedi matin vers 08h30.

Les TG Dynamique : Là, plus compliqué à identifier et isolé. Avec Patrice et une bardée de tests, il est apparu l’unicité d’affectation d’un TG dynamique.
Toujours avec Rudy, la qualification précise étant faite, nous avons pu trouver dans des tables que les affectations dynamiques étaient passées en unicités …. donc une seule affectation à la fois. Teint, pile poil le problème constatés !
Hop, re-tag les entrées des tables pour virer cette unicité, et hop c’est repartie nickel (La c’est merci à F4EGG pour les tests en live)

Fin des soucis : \o/
Le BM est maintenant revenu en état nominal.

Merci à tous pour les retours construits sur les problèmes rencontrer, dès que l’on identifie et qualifie un problème, il est déjà presque résolu 😉

A bientôt, et par forcément pour des soucis 😉

Partager par....Email this to someoneShare on FacebookShare on Google+Tweet about this on Twitter